Just got a system installed and a couple of problems...

Discussion in 'Car & Audio' started by ProBeatz, Jun 19, 2003.

Thread Status:
Not open for further replies.
  1. ProBeatz

    ProBeatz OK

    Joined:
    Jul 20, 2002
    Messages:
    2,554
    When I try to floor it or accelerate fast the car feels like its going to stall...also, when going around turns sometimes the gas gives way...something to do with a power source im guessing but can anyone give me specific help...i have a 1997 mazda 626
    test
  2. lpoet

    lpoet POET

    Joined:
    Oct 20, 2002
    Messages:
    12,678
    doesnt sound good
    test
  3. LYFE-LINE

    LYFE-LINE New Member

    Joined:
    Feb 27, 2003
    Messages:
    496
    lots of things can factor into this...do your basic checks..check your spark plugs...and wires...sounds like your missin a spark in a cylinder...next get a Fuel Injection clear and add it to your gas tank next time you fill it up...might have build up on your injectors...get a oil change and add some "Engine Restore"...could be your fuel pump goin bad...but if you step on your accelerator and it stutters...im pretty sure its your spark plugs and wires....so do the basic checks...if all else fails see a mechanic....or get a tune up...
    test
  4. Mellow Madness

    Mellow Madness aKa sTaTiK

    Joined:
    Aug 21, 2002
    Messages:
    46,575
    Either Wut He Said ^^

    Or Your Amp Isn't Pushing Enuff Watts Making Ur Cars Battery Rely To Much On The Pushing.. That Shit Will Kill Ur Car Quick.
    test
Thread Status:
Not open for further replies.

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)