Focusrite Saffire Pro 14 (HELP)

Discussion in 'Audio Help & Tips' started by Pr0spect, Feb 16, 2011.

Thread Status:
Not open for further replies.
  1. Pr0spect

    Pr0spect New Member

    Joined:
    Dec 22, 2010
    Messages:
    99
    I've got Windows 7, 32 Bit.

    I basically can't get the Audio interface to work,

    I Installed the disc with the audio interface, turned off computer, plugged firewire in and turned computer on.

    The Firewire powered the Saffire Pro but it didn't show up as connected when I looked in device manager?

    And when I opened the program with the saffire pro it said hardware not connected connect firewire cable?

    Someone said to go in bios and enable firewire but I can't see anything to do with firewire in bios?


    Please help, thanks!
    test
  2. Mr. ROUSH

    Mr. ROUSH WWW.SOUNDCLICK.COM/ROUSH

    Joined:
    Oct 6, 2000
    Messages:
    5,166
    I wouldn't think that you need to do anything to the bios.. your firewire card should already be activated.. it's not impossible, but what you'd be looking for is the specific name of the firewire card you have followed by the model number... this sounds more like a driver issue.. have you updated to the latest drivers for w7 for the Saffire? Once you do get windows to recognize the device you should also do any firmware updates that are available.. The best route for you will be to call Focusrite and they can walk you through the diagnostics.. good luck.
    test
Thread Status:
Not open for further replies.

Share This Page

Users Viewing Thread (Users: 0, Guests: 0)